andrey

Путь к Файлу: /МГУТиУ / 1 курс 2708 пфо / методички / 06 Информатика (все специальности) / Лаб_практ / Excel / Лаб3.doc

Ознакомиться или скачать весь учебный материал данного пользователя
Скачиваний:   0
Пользователь:   andrey
Добавлен:   13.01.2015
Размер:   116.5 КБ
СКАЧАТЬ

: Работа №3. Использование функций ЕСЛИ()

Лаб3Расчет праздничных премий

Задание. Начислить праздничные премии работникам организации.

Решим пример последовательно усложняя его условия.

1. Положим, текущий месяц март и женщинам устанавливается премия в размере 300 руб. ко дню 8 марта. Иными словами

<премия>=ЕСЛИ(работник=женщина, то 300р.,

в противном случае 0р.).

2. Очевидно, что такое решение будет правильным в единственном месяце – марте. Если оставить все как есть, в апреле женщинам будет также назначена премия, которой, конечно, не должно быть. Чтобы учесть этот фактор нужно выяснить и учесть значение текущего месяца (клетка В1).

<премия>=ЕСЛИ(работник=женщина И месяц=март, то 300р, иначе 0р).

3. Положим, также, что в феврале и мужчинам назначается премия.

<премия>=ЕСЛИ((работник=женщина И месяц=март)

ИЛИ (работник=мужчина И месяц=февраль), то 300р, иначе 0р).

4. Положим, что премия мужчинам и женщинам назначается по разному: мужчинам 10% от зарплаты, женщинам – 300 руб. независимо от заработка.

<премия>=ЕСЛИ(работник=женщина И месяц=март, то 300 р,

ЕСЛИ(работник=мужчина И месяц=февраль, то 10% от зарплаты, иначе 0 р)).

или несколько проще, если разбить выражение на два слагаемых

<премия>=ЕСЛИ(работник=женщина И месяц=март, то 300р)+

ЕСЛИ(работник=мужчина И месяц=февраль, то 10% зарплаты).

5. Положим, что, кроме того, всем работникам назначается премия к Новому году в размере 500 руб. (представим эти величины как отдельные слагаемые).

<премия>=ЕСЛИ(пол=женский И месяц=март, то 300р)

+ЕСЛИ(пол=мужской И месяц=февраль, 10% зарплаты)+ЕСЛИ(месяц=январь, 500р)).

 

Лаб3Табулирование кусочно-ломанной функций

Задание. Вычислить значения кусочно-ломанной функции Y(X) вида

Лаб3                                               5+Х                        при Х<0

                               Y=          5                             при 0£Х<10

                                               10–0,5X                при 10£Х

 

в диапазоне изменения аргумента Х от –6 до +16 с шагом 2. Значения Х и Y находятся в строках 1 и 2 таблицы.

 

 

A

B

C

D

E

F

G

H

I

J

K

L

M

1

X

–6

–4

–2

0

2

4

6

8

10

12

14

16

2

Y

–1

1

3

5

5

5

5

5

5

4

3

2

 

Здесь                             Y = ЕСЛИ(Х<0;5+Х;ЕСЛИ(И(0<=Х;Х<10);5;10–0,5*Х))

или                                        B2=ЕСЛИ(B1<0;5+B1;ЕСЛИ(И(0<=B1;B1<10);5;10–0,5*B1))

или проще                           B2=ЕСЛИ(B1<0;5+B1;ЕСЛИ(B1<=10;5;10–0,5*B1)).

Упрощение стало возможным поскольку, если условие В1<0 неверно, значит обязательно верно противоположное В1>=0. Таким образом, выяснять это больше не нужно и вместо выражения вида И(0<=B1;B1<10) можно ограничиться только B1<10. График функции, построенный с помощью средств деловой графики Excel, приведен справа.

Задание. Построить периодическую функцию Y(X) (варианты приведены на рисунке ниже). Шаг изменения данных по вертикали (Y) равен 1.

 

Лаб3 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


Указания к решению задачи.

· Описать все участки функции аналитически для одного периода изменения Х и составить клеточное выражение.

· Построить таблицу (расположить вертикально) и график для одного периода.

· Используя функцию ОСТАТ(Х;<период>) вместо Х, модифицировать выражение таким образом, чтобы оно было пригодно на всей оси Х.

· Построить таблицу и график для нескольких (двух) периодов.

Лаб3Перераспределение собственности

Задание. Создать таблицу перераспределения собственности акционерного общества при приеме новых пай.

Положим, существующие (старые) акционеры имеют голоса (столбец С) в управлении предприятием и распределении прибыли в соответствии со стоимостью их пакетов акций (столбец В). Положим также, что фирма испытывает финансовые затруднения и ей нужны новые инвесторы, которые готовы внести необходимую для поддержания деятельности компании сумму в 700 тыс. рублей (по 400 и 300 тыс. руб. соответственно). Следует определить новые права каждого из новых и старых пайщиков.

Лаб3Сдельная зарплата

Задание. Рассчитать размер сдельной заработной платы. Известны: стоимость обработки одной детали (10руб), стоимость испорченной детали (20руб). Последняя вычитается из зарплаты Если бракованных деталей много, зарплата может оказаться отрицательной. Здесь, конечно и премия и налог должны быть равны 0.

Повременная (почасовая) зарплата с учетом доплат за работу в выходные

Задание. Вычислить величину повременной оплаты труда за смену.

 

A

B

C

D

E

F

1

Час:

Доплата

в выход.

80%

 

2

Почасовая зарплата

3

Работник

Дата

Часов

Зарплата

Доплата

Всего

4

Петр

01.01.99 Пт

9

18

2,0

20,0

5

Иван

02.01.99 Сб

4

8

6,4

14,4

6

Олег

03.01.99 Вс

5

10

8,0

18,0

7

Сергей

04.01.99 Пн

5

10

0,0

10,0

8

Всего

 

23

46

16,4

62,4

 

Известны: стоимость одного часа работы. Кроме основного тарифа (2 руб. в час) имеются и доплаты. В субботу и воскресение тариф увеличивается на 80%. Кроме того, сверхурочная работа (т.е. часы отработанные свыше 8-часовой смены) оплачиваются по двойному тарифу. Здесь, для выявления дня недели нам понадобится функция ДЕНЬНЕД(<дата>,2).

 

Наверх страницы

Внимание! Не забудьте ознакомиться с остальными документами данного пользователя!

Соседние файлы в текущем каталоге:

На сайте уже 21970 файлов общим размером 9.9 ГБ.

Наш сайт представляет собой Сервис, где студенты самых различных специальностей могут делиться своей учебой. Для удобства организован онлайн просмотр содержимого самых разных форматов файлов с возможностью их скачивания. У нас можно найти курсовые и лабораторные работы, дипломные работы и диссертации, лекции и шпаргалки, учебники, чертежи, инструкции, пособия и методички - можно найти любые учебные материалы. Наш полезный сервис предназначен прежде всего для помощи студентам в учёбе, ведь разобраться с любым предметом всегда быстрее когда можно посмотреть примеры, ознакомится более углубленно по той или иной теме. Все материалы на сайте представлены для ознакомления и загружены самими пользователями. Учитесь с нами, учитесь на пятерки и становитесь самыми грамотными специалистами своей профессии.

Не нашли нужный документ? Воспользуйтесь поиском по содержимому всех файлов сайта:



Каждый день, проснувшись по утру, заходи на obmendoc.ru

Товарищ, не ленись - делись файлами и новому учись!

Яндекс.Метрика